Installation#


Using pip#

The pip3 package manager must be installed on the machine where the SDK will be installed and used.

To install the 5.1.0 release of the library, use your Python 3 installation’s instance of pip:

$ pip3 install streamsets~=5.0

Note: You do not need any activation key.

Versioning#

To use the functionality of StreamSets DataOps Platform, the major version of StreamSets DataOps Platform SDK for Python should be greater than or equal to 4.0.0.

An engine runs StreamSets pipelines. StreamSets has three engines, Data Collector, Transformer and Transformer for Snowflake.

For more details, refer to the StreamSets DataOps Platform Documentation.

If you wish to use Data Collector with StreamSets DataOps Platform SDK for Python, start and deploy a Data Collector of version greater than or equal to 4.0.2 with StreamSets DataOps Platform.

If you wish to use Transformer with StreamSets DataOps Platform SDK for Python, start and deploy a Transformer of version greater than or equal to 4.0.0 with StreamSets DataOps Platform.

If you wish to use Transformer for Snowflake with StreamSets DataOps Platform SDK for Python, you don’t need to start any engines, just select the desired execution mode when using the SDK.